Skip to content

Spoofax 2.4.1 (29-01-2018)

Spoofax 2.4.1 is a minor bugfix release.

Changes

  • Fix: remove dependency on nativebundle from jsglr2, preventing native binaries (with a cygwin vulnerability) from showing up in Spoofax Core.
  • Update jackson-core, jackson-databind, jackson-annotations, jackson-dataformat-yaml dependencies to 2.9.3 to avoid a vulnerability in those libraries.
  • Update commons-configuration2 to 2.2, commons-configuration2-jackson to 0.7.0, and snakeyaml to 1.18, for compatibility with jackson version 2.9.3.

Downloads

Eclipse plugin

Premade Eclipse installations

With embedded JRE:

Without embedded JRE:

Update site

  • Eclipse update site: https://artifacts.metaborg.org/content/unzip/releases-unzipped/org/metaborg/org.metaborg.spoofax.eclipse.updatesite/2.4.1/org.metaborg.spoofax.eclipse.updatesite-2.4.1-assembly.zip-unzip/
  • Eclipse update site archive

IntelliJ plugin

  • IntelliJ update site: https://artifacts.metaborg.org/service/local/artifact/maven/redirect?r=releases&g=org.metaborg&a=org.metaborg.intellij.dist&p=zip&v=2.4.1
  • IntelliJ update site archive

Command-line utilities

Core API

  • Spoofax Core Uber JAR
  • Spoofax Core uber Maven artifact: org.metaborg:org.metaborg.spoofax.core.uber:2.4.1

StrategoXT

Maven artifacts

Maven artifacts can be found on our artifact server. The Maven version used for this release is 2.4.1.


Last update: 2021-11-15
Back to top